Dansk Arch Linux forum

For det danske Arch Linux community

Du er ikke logget ind.


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 406

#1 21-02-2012 19:44:26

Pawsen
Ny på Archforum
Registreret: 01-06-2010
Indlæg: 16

[LØST] Udev indlæser ikke drivere

[løst] - se næste indlæg. Der var ingen fejl.

Hej

Jeg har følgende problem:

I den virtuelle terminal virker tastetur som det skal.

Men når jeg logger ind i X, stopper alle input-devices med at virke, dvs tastetur, mus, trackpad reagerere ikke.
Ifølge Xorgs's log, fordi udev ikke kan finde nogle drivere.
Jeg synes ikke at have installeret programmer der bør have noget med Xorg at gøre på det seneste. Og i går virkede computeren fint - dog installerede jeg også nogle få programmer og genstartede ikke derefter. Se log fra pacman.

Det har ingen betydning om jeg logger ind i Awesome(WM) eller gnome.
Mit grafikkort er Nvidia og jeg bruger de proprietære drivere.

Jeg bruger ikke nogen logon-manager, men inittab til at logge automatisk  ind på den virtuelle konsol og derfra videre med startx

Logs:

pacman.log:

Kode:

[2012-02-19 12:56] Running 'pacman-color -S laptop-mode'
[2012-02-19 12:56] Running 'pacman-color -S laptop-mode-tools'
[2012-02-19 12:57] upgraded laptop-mode-tools (1.60-1 -> 1.60-1)
[2012-02-19 12:59] Running 'pacman-color -Rs laptop-mode-tools'
[2012-02-19 12:59] warning: /etc/laptop-mode/conf.d/usb-autosuspend.conf saved as /etc/laptop-mode/conf.d/usb-autosuspend.conf.pacsave
[2012-02-19 12:59] removed laptop-mode-tools (1.60-1)
[2012-02-19 12:59] removed hdparm (9.39-1)
[2012-02-19 14:22] Running 'pacman-color -Syu'
[2012-02-19 14:22] synchronizing package lists
[2012-02-19 14:22] starting full system upgrade
[2012-02-19 14:22] upgraded gsm (1.0.13-6 -> 1.0.13-7)
[2012-02-19 14:22] upgraded gtk-recordmydesktop (0.3.8-5 -> 0.3.8-6)
[2012-02-19 14:22] upgraded libid3tag (0.15.1b-6 -> 0.15.1b-7)
[2012-02-19 14:22] upgraded libieee1284 (0.2.11-3 -> 0.2.11-4)
[2012-02-19 14:22] upgraded libirman (0.4.5-2 -> 0.4.5-3)
[2012-02-19 14:22] upgraded libmodplug (0.8.8.3-1 -> 0.8.8.4-1)
[2012-02-19 14:22] upgraded libzip (0.10-1 -> 0.10-2)
[2012-02-19 14:22] upgraded lsb-release (1.4-10 -> 1.4-11)
[2012-02-19 14:22] upgraded neon (0.29.6-2 -> 0.29.6-3)
[2012-02-19 14:22] upgraded openbox (3.5.0-4 -> 3.5.0-5)
[2012-02-19 14:22] upgraded openobex (1.5-2 -> 1.5-3)
[2012-02-19 14:22] upgraded p11-kit (0.9-1 -> 0.11-1)
[2012-02-19 14:22] upgraded perl-error (0.17016-2 -> 0.17017-1)
[2012-02-19 14:22] upgraded sudo (1.8.3.p2-2 -> 1.8.4-1)
[2012-02-19 14:22] upgraded taglib (1.7-3 -> 1.7-4)
[2012-02-19 14:22] upgraded tint2 (0.11-4 -> 0.11-5)
[2012-02-19 14:22] upgraded vlc (1.1.13-6 -> 2.0.0-1)
[2012-02-19 16:45] Running 'pacman-color -Syu'
[2012-02-19 16:45] synchronizing package lists
[2012-02-19 16:45] starting full system upgrade
[2012-02-20 19:24] Running 'pacman-color -Syu'
[2012-02-20 19:24] synchronizing package lists
[2012-02-20 19:24] starting full system upgrade
[2012-02-20 19:33] Running 'pacman-color -Syu'
[2012-02-20 19:33] synchronizing package lists
[2012-02-20 19:33] starting full system upgrade
[2012-02-20 19:33] upgraded dictd (1.12.0-3 -> 1.12.0-4)
[2012-02-20 19:33] upgraded filesystem (2011.12-2 -> 2012.2-2)
[2012-02-20 19:33] upgraded gnutls (3.0.12-1 -> 3.0.13-1)
[2012-02-20 19:33] upgraded pyxdg (0.19-2 -> 0.19-3)
[2012-02-20 19:33] upgraded vlc (2.0.0-1 -> 2.0.0-3)
[2012-02-20 23:57] Running 'pacman -S extra/laptop-mode-tools'
[2012-02-20 23:57] installed hdparm (9.39-1)
[2012-02-20 23:57] installed laptop-mode-tools (1.60-1)
[2012-02-20 23:58] Running 'pacman -S --asdeps --needed core/sdparm'
[2012-02-20 23:58] installed sdparm (1.07-1)
[2012-02-20 23:58] Running 'pacman -U /tmp/yaourt-tmp-paw/PKGDEST.W90/laptop-init-script-1.1-1-any.pkg.tar.xz'
[2012-02-20 23:58] installed laptop-init-script (1.1-1)
[2012-02-21 00:52] Running 'pacman -U /tmp/yaourt-tmp-paw/PKGDEST.RLG/exodusii-5.14-1-x86_64.pkg.tar.xz'
[2012-02-21 00:52] installed exodusii (5.14-1)
[2012-02-21 12:20] Running 'pacman-color -Syu'
[2012-02-21 12:20] synchronizing package lists
[2012-02-21 13:05] Running 'pacman-color -U /var/cache/pacman/pkg/mkinitcpio-0.7.2-1-any.pkg.tar.xz'
[2012-02-21 13:06] Running 'pacman-color -U /var/cache/pacman/pkg/udev-173-3-x86_64.pkg.tar.xz'rc.conf
[2012-02-21 13:07] Running 'pacman-color -U /var/cache/pacman/pkg/initscripts-201'
[2012-02-21 13:08] Running 'pacman-color -U /var/cache/pacman/pkg/initscripts-2011.12.1-1-any.pkg.tar.xz'
[2012-02-21 13:08] warning: /etc/rc.conf installed as /etc/rc.conf.pacnew
[2012-02-21 13:08] upgraded initscripts (2012.02.1-1 -> 2011.12.1-1)
[2012-02-21 13:08] Running 'pacman-color -U /var/cache/pacman/pkg/udev-173-3-x86_64.pkg.tar.xz'
[2012-02-21 13:08] Running 'pacman-color -U /var/cache/pacman/pkg/mkinitcpio-0.7.2-1-any.pkg.tar.xz'

Jeg har forsøgt at nedgradere initscripts, mkinitcpio og udev. De to sidste dog uden succes.
mkinitcpio kommer med:

Kode:

mkinitcpio: /lib/initcpio/hooks/udev exist in filesystem
mkinitcpio: /lib/initcpio/install/udev exist in filesystem

Og udev kan ikke nedgrades fordi mkinitcpio afhænger af den nuværende version.

Xorg.0.log

Kode:

[   523.479] 
X.Org X Server 1.11.4
Release Date: 2012-01-27
[   523.479] X Protocol Version 11, Revision 0
[   523.479] Build Operating System: Linux 3.2.2-1-ARCH x86_64 
[   523.479] Current Operating System: Linux myhost 3.2.6-2-ARCH #1 SMP PREEMPT Thu Feb 16 10:10:02 CET 2012 x86_64
[   523.479] Kernel command line: root=/dev/sda3 resume=/dev/sda5  ro vga=773
[   523.480] Build Date: 29 January 2012  03:38:00PM
[   523.480]  
[   523.480] Current version of pixman: 0.24.4
[   523.480]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[   523.480] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   523.480] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Feb 21 13:11:39 2012
[   523.521] (II) Loader magic: 0x7ccae0
[   523.521] (II) Module ABI versions:
[   523.521]     X.Org ANSI C Emulation: 0.4
[   523.521]     X.Org Video Driver: 11.0
[   523.521]     X.Org XInput driver : 13.0
[   523.521]     X.Org Server Extension : 6.0
[   523.522] (--) PCI:*(0:1:0:0) 10de:0427:1028:0209 rev 161, Mem @ 0xf5000000/16777216, 0xe0000000/268435456, 0xf2000000/33554432, I/O @ 0x0000ef00/128, BIOS @ 0x????????/131072
[   523.523] (==) Using default built-in configuration (48 lines)
[   523.523] (==) --- Start of built-in configuration ---
[   523.523]     Section "Device"
[   523.523]         Identifier    "Builtin Default nouveau Device 0"
[   523.523]         Driver    "nouveau"
[   523.523]     EndSection
[   523.523]     Section "Screen"
[   523.523]         Identifier    "Builtin Default nouveau Screen 0"
[   523.523]         Device    "Builtin Default nouveau Device 0"
[   523.523]     EndSection
[   523.523]     Section "Device"
[   523.523]         Identifier    "Builtin Default nv Device 0"
[   523.523]         Driver    "nv"
[   523.523]     EndSection
[   523.523]     Section "Screen"
[   523.523]         Identifier    "Builtin Default nv Screen 0"
[   523.523]         Device    "Builtin Default nv Device 0"
[   523.523]     EndSection
[   523.523]     Section "Device"
[   523.523]         Identifier    "Builtin Default nvidia Device 0"
[   523.523]         Driver    "nvidia"
[   523.523]     EndSection
[   523.523]     Section "Screen"
[   523.523]         Identifier    "Builtin Default nvidia Screen 0"
[   523.523]         Device    "Builtin Default nvidia Device 0"
[   523.523]     EndSection
[   523.523]     Section "Device"
[   523.523]         Identifier    "Builtin Default vesa Device 0"
[   523.523]         Driver    "vesa"
[   523.523]     EndSection
[   523.523]     Section "Screen"
[   523.523]         Identifier    "Builtin Default vesa Screen 0"
[   523.523]         Device    "Builtin Default vesa Device 0"
[   523.523]     EndSection
[   523.523]     Section "Device"
[   523.523]         Identifier    "Builtin Default fbdev Device 0"
[   523.523]         Driver    "fbdev"
[   523.523]     EndSection
[   523.523]     Section "Screen"
[   523.523]         Identifier    "Builtin Default fbdev Screen 0"
[   523.523]         Device    "Builtin Default fbdev Device 0"
[   523.523]     EndSection
[   523.523]     Section "ServerLayout"
[   523.523]         Identifier    "Builtin Default Layout"
[   523.523]         Screen    "Builtin Default nouveau Screen 0"
[   523.523]         Screen    "Builtin Default nv Screen 0"
[   523.523]         Screen    "Builtin Default nvidia Screen 0"
[   523.523]         Screen    "Builtin Default vesa Screen 0"
[   523.523]         Screen    "Builtin Default fbdev Screen 0"
[   523.523]     EndSection
[   523.523] (==) --- End of built-in configuration ---
[   523.523] (==) ServerLayout "Builtin Default Layout"
[   523.523] (**) |-->Screen "Builtin Default nouveau Screen 0" (0)
[   523.523] (**) |   |-->Monitor "<default monitor>"
[   523.541] (**) |   |-->Device "Builtin Default nouveau Device 0"
[   523.541] (==) No monitor specified for screen "Builtin Default nouveau Screen 0".
    Using a default monitor configuration.
[   523.541] (**) |-->Screen "Builtin Default nv Screen 0" (1)
[   523.541] (**) |   |-->Monitor "<default monitor>"
[   523.541] (**) |   |-->Device "Builtin Default nv Device 0"
[   523.541] (==) No monitor specified for screen "Builtin Default nv Screen 0".
    Using a default monitor configuration.
[   523.542] (**) |-->Screen "Builtin Default nvidia Screen 0" (2)
[   523.542] (**) |   |-->Monitor "<default monitor>"
[   523.542] (**) |   |-->Device "Builtin Default nvidia Device 0"
[   523.542] (==) No monitor specified for screen "Builtin Default nvidia Screen 0".
    Using a default monitor configuration.
[   523.542] (**) |-->Screen "Builtin Default vesa Screen 0" (3)
[   523.542] (**) |   |-->Monitor "<default monitor>"
[   523.542] (**) |   |-->Device "Builtin Default vesa Device 0"
[   523.542] (==) No monitor specified for screen "Builtin Default vesa Screen 0".
    Using a default monitor configuration.
[   523.542] (**) |-->Screen "Builtin Default fbdev Screen 0" (4)
[   523.542] (**) |   |-->Monitor "<default monitor>"
[   523.542] (**) |   |-->Device "Builtin Default fbdev Device 0"
[   523.542] (==) No monitor specified for screen "Builtin Default fbdev Screen 0".
    Using a default monitor configuration.
[   523.542] (==) Automatically adding devices
[   523.542] (==) Automatically enabling devices
[   523.577] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[   523.577]     Entry deleted from font path.
[   523.629] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[   523.629]     Entry deleted from font path.
[   523.629]     (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[   523.629] (==) FontPath set to:
    /usr/share/fonts/misc/,
    /usr/share/fonts/TTF/,
    /usr/share/fonts/Type1/,
    /usr/share/fonts/100dpi/
[   523.629] (==) ModulePath set to "/usr/lib/xorg/modules"
[   523.630] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[   523.630] (II) Open ACPI successful (/var/run/acpid.socket)
[   523.630] (II) LoadModule: "extmod"
[   523.652] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[   523.661] (II) Module extmod: vendor="X.Org Foundation"
[   523.661]     compiled for 1.11.4, module version = 1.0.0
[   523.661]     Module class: X.Org Server Extension
[   523.661]     ABI class: X.Org Server Extension, version 6.0
[   523.661] (II) Loading extension MIT-SCREEN-SAVER
[   523.661] (II) Loading extension XFree86-VidModeExtension
[   523.661] (II) Loading extension XFree86-DGA
[   523.661] (II) Loading extension DPMS
[   523.661] (II) Loading extension XVideo
[   523.661] (II) Loading extension XVideo-MotionCompensation
[   523.661] (II) Loading extension X-Resource
[   523.661] (II) LoadModule: "dbe"
[   523.662] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[   523.671] (II) Module dbe: vendor="X.Org Foundation"
[   523.671]     compiled for 1.11.4, module version = 1.0.0
[   523.671]     Module class: X.Org Server Extension
[   523.671]     ABI class: X.Org Server Extension, version 6.0
[   523.671] (II) Loading extension DOUBLE-BUFFER
[   523.671] (II) LoadModule: "glx"
[   523.687] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   524.358] (II) Module glx: vendor="NVIDIA Corporation"
[   524.368]     compiled for 4.0.2, module version = 1.0.0
[   524.368]     Module class: X.Org Server Extension
[   524.368] (II) NVIDIA GLX Module  295.20  Mon Feb  6 21:28:16 PST 2012
[   524.368] (II) Loading extension GLX
[   524.368] (II) LoadModule: "record"
[   524.368] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[   524.385] (II) Module record: vendor="X.Org Foundation"
[   524.385]     compiled for 1.11.4, module version = 1.13.0
[   524.385]     Module class: X.Org Server Extension
[   524.385]     ABI class: X.Org Server Extension, version 6.0
[   524.385] (II) Loading extension RECORD
[   524.385] (II) LoadModule: "dri"
[   524.385] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[   524.400] (II) Module dri: vendor="X.Org Foundation"
[   524.400]     compiled for 1.11.4, module version = 1.0.0
[   524.400]     ABI class: X.Org Server Extension, version 6.0
[   524.400] (II) Loading extension XFree86-DRI
[   524.400] (II) LoadModule: "dri2"
[   524.400] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   524.415] (II) Module dri2: vendor="X.Org Foundation"
[   524.415]     compiled for 1.11.4, module version = 1.2.0
[   524.415]     ABI class: X.Org Server Extension, version 6.0
[   524.415] (II) Loading extension DRI2
[   524.415] (II) LoadModule: "nouveau"
[   524.438] (WW) Warning, couldn't open module nouveau
[   524.438] (II) UnloadModule: "nouveau"
[   524.438] (II) Unloading nouveau
[   524.438] (EE) Failed to load module "nouveau" (module does not exist, 0)
[   524.438] (II) LoadModule: "nv"
[   524.439] (WW) Warning, couldn't open module nv
[   524.439] (II) UnloadModule: "nv"
[   524.439] (II) Unloading nv
[   524.439] (EE) Failed to load module "nv" (module does not exist, 0)
[   524.439] (II) LoadModule: "nvidia"
[   524.439] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[   524.530] (II) Module nvidia: vendor="NVIDIA Corporation"
[   524.530]     compiled for 4.0.2, module version = 1.0.0
[   524.530]     Module class: X.Org Video Driver
[   524.566] (II) LoadModule: "vesa"
[   524.566] (WW) Warning, couldn't open module vesa
[   524.566] (II) UnloadModule: "vesa"
[   524.566] (II) Unloading vesa
[   524.566] (EE) Failed to load module "vesa" (module does not exist, 0)
[   524.566] (II) LoadModule: "fbdev"
[   524.566] (WW) Warning, couldn't open module fbdev
[   524.566] (II) UnloadModule: "fbdev"
[   524.566] (II) Unloading fbdev
[   524.566] (EE) Failed to load module "fbdev" (module does not exist, 0)
[   524.566] (II) NVIDIA dlloader X Driver  295.20  Mon Feb  6 21:09:10 PST 2012
[   524.566] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   524.581] (--) using VT number 7

[   524.620] (II) Loading sub module "fb"
[   524.620] (II) LoadModule: "fb"
[   524.621] (II) Loading /usr/lib/xorg/modules/libfb.so
[   524.642] (II) Module fb: vendor="X.Org Foundation"
[   524.642]     compiled for 1.11.4, module version = 1.0.0
[   524.642]     ABI class: X.Org ANSI C Emulation, version 0.4
[   524.642] (II) Loading sub module "wfb"
[   524.642] (II) LoadModule: "wfb"
[   524.642] (II) Loading /usr/lib/xorg/modules/libwfb.so
[   524.657] (II) Module wfb: vendor="X.Org Foundation"
[   524.657]     compiled for 1.11.4, module version = 1.0.0
[   524.657]     ABI class: X.Org ANSI C Emulation, version 0.4
[   524.657] (II) Loading sub module "ramdac"
[   524.657] (II) LoadModule: "ramdac"
[   524.657] (II) Module "ramdac" already built-in
[   524.657] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[   524.657] (II) Loading /usr/lib/xorg/modules/libwfb.so
[   524.657] (II) Loading /usr/lib/xorg/modules/libfb.so
[   524.681] (II) NVIDIA(0): Creating default Display subsection in Screen section
    "Builtin Default nvidia Screen 0" for depth/fbbpp 24/32
[   524.681] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[   524.681] (==) NVIDIA(0): RGB weight 888
[   524.681] (==) NVIDIA(0): Default visual is TrueColor
[   524.681] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   524.681] (**) NVIDIA(0): Enabling 2D acceleration
[   526.624] (II) NVIDIA(GPU-0): Display (Seiko/Epson (DFP-0)) does not support NVIDIA 3D
[   526.624] (II) NVIDIA(GPU-0):     Vision stereo.
[   526.631] (II) NVIDIA(0): NVIDIA GPU GeForce 8400M GS (G86M) at PCI:1:0:0 (GPU-0)
[   526.631] (--) NVIDIA(0): Memory: 262144 kBytes
[   526.631] (--) NVIDIA(0): VideoBIOS: 60.86.45.00.40
[   526.631] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[   526.631] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[   526.631] (--) NVIDIA(0): Connected display device(s) on GeForce 8400M GS at PCI:1:0:0
[   526.631] (--) NVIDIA(0):     Seiko/Epson (DFP-0)
[   526.631] (--) NVIDIA(0): Seiko/Epson (DFP-0): 330.0 MHz maximum pixel clock
[   526.631] (--) NVIDIA(0): Seiko/Epson (DFP-0): Internal Dual Link LVDS
[   526.636] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[   526.636] (**) NVIDIA(0):     device Seiko/Epson (DFP-0) (Using EDID frequencies has
[   526.636] (**) NVIDIA(0):     been enabled on all display devices.)
[   526.685] (II) NVIDIA(0): Assigned Display Device: DFP-0
[   526.685] (==) NVIDIA(0): 
[   526.685] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[   526.685] (==) NVIDIA(0):     will be used as the requested mode.
[   526.685] (==) NVIDIA(0): 
[   526.686] (II) NVIDIA(0): Validated modes:
[   526.686] (II) NVIDIA(0):     "nvidia-auto-select"
[   526.686] (II) NVIDIA(0): Virtual screen size determined to be 1280 x 800
[   527.697] (--) NVIDIA(0): DPI set to (112, 112); computed from "UseEdidDpi" X config
[   527.697] (--) NVIDIA(0):     option
[   527.697] (--) Depth 24 pixmap format is 32 bpp
[   527.697] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
[   527.710] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
[   528.059] (II) Loading extension NV-GLX
[   528.207] (==) NVIDIA(0): Disabling shared memory pixmaps
[   528.207] (==) NVIDIA(0): Backing store disabled
[   528.207] (==) NVIDIA(0): Silken mouse enabled
[   528.207] (==) NVIDIA(0): DPMS enabled
[   528.207] (II) Loading extension NV-CONTROL
[   528.208] (II) Loading extension XINERAMA
[   528.208] (II) Loading sub module "dri2"
[   528.208] (II) LoadModule: "dri2"
[   528.208] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   528.208] (II) Module dri2: vendor="X.Org Foundation"
[   528.208]     compiled for 1.11.4, module version = 1.2.0
[   528.208]     ABI class: X.Org Server Extension, version 6.0
[   528.208] (II) NVIDIA(0): [DRI2] Setup complete
[   528.208] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[   528.208] (==) RandR enabled
[   528.208] (II) Initializing built-in extension Generic Event Extension
[   528.208] (II) Initializing built-in extension SHAPE
[   528.208] (II) Initializing built-in extension MIT-SHM
[   528.208] (II) Initializing built-in extension XInputExtension
[   528.208] (II) Initializing built-in extension XTEST
[   528.208] (II) Initializing built-in extension BIG-REQUESTS
[   528.208] (II) Initializing built-in extension SYNC
[   528.208] (II) Initializing built-in extension XKEYBOARD
[   528.208] (II) Initializing built-in extension XC-MISC
[   528.208] (II) Initializing built-in extension SECURITY
[   528.208] (II) Initializing built-in extension XINERAMA
[   528.208] (II) Initializing built-in extension XFIXES
[   528.208] (II) Initializing built-in extension RENDER
[   528.208] (II) Initializing built-in extension RANDR
[   528.208] (II) Initializing built-in extension COMPOSITE
[   528.208] (II) Initializing built-in extension DAMAGE
[   528.210] (II) Initializing extension GLX
[   528.797] (II) config/udev: Adding input device Video Bus (/dev/input/event1)
[   528.797] (II) No input driver specified, ignoring this device.
[   528.797] (II) This device may have been added with another device file.
[   528.798] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[   528.798] (II) No input driver specified, ignoring this device.
[   528.798] (II) This device may have been added with another device file.
[   528.798] (II) config/udev: Adding input device Lid Switch (/dev/input/event2)
[   528.798] (II) No input driver specified, ignoring this device.
[   528.798] (II) This device may have been added with another device file.
[   528.798] (II) config/udev: Adding input device Sleep Button (/dev/input/event4)
[   528.798] (II) No input driver specified, ignoring this device.
[   528.798] (II) This device may have been added with another device file.
[   528.798] (II) config/udev: Adding input device Broadcom Corp (/dev/input/event13)
[   528.799] (II) No input driver specified, ignoring this device.
[   528.799] (II) This device may have been added with another device file.
[   528.799] (II) config/udev: Adding input device Broadcom Corp (/dev/input/event14)
[   528.799] (II) No input driver specified, ignoring this device.
[   528.799] (II) This device may have been added with another device file.
[   528.799] (II) config/udev: Adding input device Broadcom Corp (/dev/input/mouse1)
[   528.799] (II) No input driver specified, ignoring this device.
[   528.799] (II) This device may have been added with another device file.
[   528.799] (II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event7)
[   528.799] (II) No input driver specified, ignoring this device.
[   528.799] (II) This device may have been added with another device file.
[   528.800] (II) config/udev: Adding input device HDA Intel Headphone (/dev/input/event10)
[   528.800] (II) No input driver specified, ignoring this device.
[   528.800] (II) This device may have been added with another device file.
[   528.800] (II) config/udev: Adding input device HDA Intel Headphone (/dev/input/event11)
[   528.800] (II) No input driver specified, ignoring this device.
[   528.800] (II) This device may have been added with another device file.
[   528.800] (II) config/udev: Adding input device HDA Intel Mic (/dev/input/event9)
[   528.800] (II) No input driver specified, ignoring this device.
[   528.800] (II) This device may have been added with another device file.
[   528.800] (II) config/udev: Adding input device Sun USB Keyboard (/dev/input/event15)
[   528.800] (II) No input driver specified, ignoring this device.
[   528.800] (II) This device may have been added with another device file.
[   528.801] (II) config/udev: Adding input device Laptop Integrated Webcam (/dev/input/event12)
[   528.801] (II) No input driver specified, ignoring this device.
[   528.801] (II) This device may have been added with another device file.
[   528.801] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[   528.801] (II) No input driver specified, ignoring this device.
[   528.801] (II) This device may have been added with another device file.
[   528.801] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event8)
[   528.801] (II) No input driver specified, ignoring this device.
[   528.801] (II) This device may have been added with another device file.
[   528.801] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[   528.801] (II) No input driver specified, ignoring this device.
[   528.801] (II) This device may have been added with another device file.
[   528.802] (II) config/udev: Adding input device PC Speaker (/dev/input/event5)
[   528.802] (II) No input driver specified, ignoring this device.
[   528.802] (II) This device may have been added with another device file.
[   528.802] (II) config/udev: Adding input device Dell WMI hotkeys (/dev/input/event6)
[   528.802] (II) No input driver specified, ignoring this device.
[   528.802] (II) This device may have been added with another device file.

Som det ses loades Nvidia driveren først. Men herefter forsøger den at loade nouveau. Hvorfor ved jeg ikke.
Jeg mindes ikke at have installeret driveren på noget tidspunkt, og 'pacman -Qs nou*' viser den ikke.
Ligeledes kan bfdev, vesa mv ikke loades. Vesa tror jeg heller ikke er installeret.

Til sidst kommer meddelelserne om at udev ikke kan finde drivere.

startx

Kode:

X.Org X Server 1.11.4
Release Date: 2012-01-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.2-1-ARCH x86_64 
Current Operating System: Linux myhost 3.2.6-2-ARCH #1 SMP PREEMPT Thu Feb 16 10:10:02 CET 2012 x86_64
Kernel command line: root=/dev/sda3 resume=/dev/sda5  ro vga=773
Build Date: 29 January 2012  03:38:00PM
 
Current version of pixman: 0.24.4
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Feb 21 13:11:39 2012
(==) Using default built-in configuration (48 lines)
(EE) Failed to load module "nouveau" (module does not exist, 0)
(EE) Failed to load module "nv" (module does not exist, 0)
(EE) Failed to load module "vesa" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
W: awesome: xerror:809: X error: request=GrabKey, error=BadAccess
W: awesome: xerror:809: X error: request=GrabKey, error=BadAccess
W: awesome: xerror:809: X error: request=GrabKey, error=BadAccess
W: awesome: xerror:809: X error: request=GrabKey, error=BadAccess
W: awesome: xerror:809: X error: request=GrabKey, error=BadAccess
W: awesome: xerror:809: X error: request=GrabKey, error=BadAccess
W: awesome: xerror:809: X error: request=GrabKey, error=BadAccess
W: awesome: xerror:809: X error: request=GrabKey, error=BadAccess
W: awesome: xerror:809: X error: request=GrabKey, error=BadAccess
W: awesome: xerror:809: X error: request=GrabKey, error=BadAccess
W: awesome: xerror:809: X error: request=GrabKey, error=BadAccess
W: awesome: xerror:809: X error: request=GrabKey, error=BadAccess
W: awesome: xerror:809: X error: request=GrabKey, error=BadAccess
W: awesome: xerror:809: X error: request=GrabKey, error=BadAccess
W: awesome: xerror:809: X error: request=GrabKey, error=BadAccess
W: awesome: xerror:809: X error: request=GreabKey, error=BadAccess

Fejlen fra Awesome har jeg ikke lagt mærke til før(jeg har aldrig tjekket), men som sagt er problemet der også når gnome bruges i stedet.
Hvis nogle ved hvad det skyldes, hører jeg det gerne.

rc.conf

Kode:

DAEMONS=(@syslog-ng dbus wicd netfs @sensors @alsa @crond acpid @vboxdrv @sensors)

Mvh Paw

Sidst ændret af Pawsen (21-02-2012 20:15:36)

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 406

#2 21-02-2012 20:15:00

Pawsen
Ny på Archforum
Registreret: 01-06-2010
Indlæg: 16

Re: [LØST] Udev indlæser ikke drivere

Løst.

Jeg beklager indlægget. Det er ganske pinligt. Og løsningen stod endda i Xorg's logfil.

Using default built-in configuration (48 lines)

eg. den kunne ikke finde /etc/X11/xorg.conf og /etc/X11/xorg.conf.d/

Sagen er den, at disse filer var soft-linket til de rigtige filer, der var placeret i en backup-mappe. Det havde jeg bare glemt alt om, og i går ryddede jeg op(dvs slettede den pågældende mappe).

Æv. Men nu virker det igen. Efter en maaasse spildte timer:)

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

#3 21-02-2012 20:57:15

julemand101
Admin
Fra: Brabrand
Registreret: 18-04-2006
Indlæg: 779
Website

Re: [LØST] Udev indlæser ikke drivere

Godt du fik det løst. Jeg skimtede lige dit første indlæg og tænkte med det samme "åh gud enten kommer jeg ikke i seng i dag eller også opgiver jeg det bare" men godt du selv løste problemet. Jeg markerer derfor tråden som løst. big_smile


Administrator for Archlinux.dk

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#4 21-02-2012 21:13:52

Pawsen
Ny på Archforum
Registreret: 01-06-2010
Indlæg: 16

Re: [LØST] Udev indlæser ikke drivere

Din generelle hjælpsomhed er fantastisk. Og at du er parat til at bruge flere timer på andres problemer siger det hele.

Det er vi mange der er glade for.

Mvh Paw

Offline

 

Board footer

Powered by FluxBB