Dansk Arch Linux forum

For det danske Arch Linux community

Du er ikke logget ind.


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#1 20-03-2009 19:48:01

Mr.Anderson
Ny på Archforum
Registreret: 20-03-2009
Indlæg: 5

Kan ikke mounte ekstern harddisk

Jeg har netop installeret Arch linux på min computer, og er helt ny herinde, umiddelbart virker det hele rigtig fint, men jeg har fået det problem at jeg ikke kan mounte min eksterne harddisk. Den er formatteret med NTFS og kommer også fint frem under Computer, men klikker man på den sker der intet. Jeg har derfor prøvet at højreklikke på den og sige "Open as administrator", hvilket resulterer i følgende meddelelse:
Unable to determine the program to run.
The item you selected cannot be open with administrator powers because the correct application cannot be determined

Jeg har søgt lidt rundt på nettet men syntes ikke umiddelbart at kunne finde en løsning.
På forhånd tak:)

Anders Ernst Nielsen

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#2 20-03-2009 19:49:16

Mr.Anderson
Ny på Archforum
Registreret: 20-03-2009
Indlæg: 5

Re: Kan ikke mounte ekstern harddisk

Det skal selvfølgeligt lige siges at jeg kører gnome:)

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

#3 21-03-2009 09:15:24

julemand101
Admin
Fra: Brabrand
Registreret: 18-04-2006
Indlæg: 780
Website

Re: Kan ikke mounte ekstern harddisk

Hvilke deamons har du i rc.conf? Har du installeret ntfs-3g?


Administrator for Archlinux.dk

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#4 21-03-2009 10:09:26

Mr.Anderson
Ny på Archforum
Registreret: 20-03-2009
Indlæg: 5

Re: Kan ikke mounte ekstern harddisk

ntfs-3g har jeg installeret, men det har ikke hjulpet.
Jeg har følgende daemons i rc.conf.: syslog-ng, network, netfs, crond, alsa, hal, og fam.

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#5 21-03-2009 10:13:32

julemand101
Admin
Fra: Brabrand
Registreret: 18-04-2006
Indlæg: 780
Website

Re: Kan ikke mounte ekstern harddisk

Tjek efter om du har installeret gnome-volume-manager. Herefter skal du tilføje dig selv til gruppen storage som gøres på følgende måde som root:
gpasswd -a dit_brugernavn storage

Hvis det stadig ikke virker så sig lige til.


Administrator for Archlinux.dk

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#6 21-03-2009 10:30:25

Mr.Anderson
Ny på Archforum
Registreret: 20-03-2009
Indlæg: 5

Re: Kan ikke mounte ekstern harddisk

Gnome volume manager er nyeste version, så det skulle ikke være problemet. Jeg har tilføjet min standard bruger til storage, dog uden at det har hjulpet. Beskeden er stadig den samme.
Hvis jeg højreklikker og siger "open with Other apllication" og vælger filhåndtering får jeg følgende meddelelse:
Could not display "computer:///USB%20Drive.drive".
Kører jeg lsusb fra terminalen kommer den fint op med navn og det hele.

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#7 21-03-2009 12:07:17

julemand101
Admin
Fra: Brabrand
Registreret: 18-04-2006
Indlæg: 780
Website

Re: Kan ikke mounte ekstern harddisk

Du har tjekket om du kan mount den ellers? Altså via terminalen "på den gode gammel måde"?


Administrator for Archlinux.dk

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#8 21-03-2009 12:44:14

Mr.Anderson
Ny på Archforum
Registreret: 20-03-2009
Indlæg: 5

Re: Kan ikke mounte ekstern harddisk

Nej, er ikke helt vildt inde i de forskellige kommandoer, er først rigtigt begyndt at bruge terminalen her på det sidste, hvad hedder den kommando du skal bruge for at mounte den, den vej?

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#9 21-03-2009 13:23:10

julemand101
Admin
Fra: Brabrand
Registreret: 18-04-2006
Indlæg: 780
Website

Re: Kan ikke mounte ekstern harddisk

Log på IRC og så ordner vi det den vej. Jeg regnede bare med at du havde lidt basal viden. Kommandoen hendder mount men eftersom jeg ikke aner noget om din diskopsætning bliver det bare en gætteleg at finde ud af at hvad din eksterne harddisk hedder.

Så log på IRC: #archlinux.dk @ irc.freenode.net


Administrator for Archlinux.dk

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 406

#10 21-03-2009 16:42:54

julemand101
Admin
Fra: Brabrand
Registreret: 18-04-2006
Indlæg: 780
Website

Re: Kan ikke mounte ekstern harddisk

Eftersom du ikke er logget på IRC lige nu kommer løsningen herinde som vi også aftalte. Det bliver nok en længere guide men det kan være andre vil få glæde af den.

Det første vi skal have styr på er årsagen til problemerne. HAL 0.5.11-7 har et "mindre" problem der gør at den ikke kan mount ntfs drev automatisk. Men da en del brugere ikke lige kan vente til næste version er der lavet dette lille fix der løser det. Jeg skal ikke kunne sige om sikkerheden er i orden så hvis man har flere brugere på sit system der alle skal have mulighed for at mount ntfs bør man nok finde en anden løsning men hvis der kun er en bruger vil der ikke være nogen problemer da jeg nok regner med man kan finde ud af at passe på hvad man laver.

Vi skal først ordne en fil med placeringen: /etc/hal/fdi/policy/20-ntfs-config-write-policy.fdi
Filen skal redigeres som root. Hvis filen ikke findes så opret den. Filen skal indeholde følgende:

Kode:

<?xml version="1.0" encoding="UTF-8"?> 
<deviceinfo version="0.2">
   <device>
       <match key="volume.fstype" string="ntfs">
           <match key="@block.storage_device:storage.hotpluggable" bool="true">
               <merge key="volume.fstype" type="string">ntfs-3g</merge>
               <merge key="volume.policy.mount_filesystem" type="string">ntfs-3g</merge>
               <append key="volume.mount.valid_options" type="strlist">locale=</append>
           </match>
       </match>
   </device>
</deviceinfo>

Herefter ordner vi følgende fil: /etc/PolicyKit/PolicyKit.conf
Filen skulle meget gerne allerede findes. Find det sted i filen hvor der står "<config version="0.1">" og indsæt følgende på en ny linje under dette:

Kode:

       <match user="$USER"> <!-- replace with your login or delete the line if you want to allow all users to manipulate devices (keep security issues in mind though) -->
               <match action="org.freedesktop.hal.storage.*">
                       <return result="yes"/>
               </match>
               <match action="hal-storage-mount-fixed-extra-options"> <!-- for internal devices mounted with extra options like a wished mount point -->
                       <return result="yes" />
               </match>
               <match action="hal-storage-mount-removable-extra-options"> <!-- for external devices mounted with extra options like a wished mount point -->
                       <return result="yes" />
               </match>
       </match>  <!-- don't forget to delete this line if you deleted the first one -->

Den sidste fil vi skal have fat i er: /usr/share/hal/fdi/policy/10osvendor/20-storage-methods.fdi
Denne fil findes allerede så der skal vi have fat i det sted hvor der står:

Kode:

      <match key="volume.fstype" string="ntfs">
        <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name" string="Linux">
          <append key="volume.mount.valid_options" type="strlist">uid=</append>
          <append key="volume.mount.valid_options" type="strlist">gid=</append>
          <append key="volume.mount.valid_options" type="strlist">umask=</append>
          <append key="volume.mount.valid_options" type="strlist">dmask=</append>
          <append key="volume.mount.valid_options" type="strlist">fmask=</append>
          <append key="volume.mount.valid_options" type="strlist">locale=</append>
          <append key="volume.mount.valid_options" type="strlist">utf8</append>
        </match>

Her skal vi have indsat de to linjer der begynder med "<merge key=" så der kommer til at stå:

Kode:

      <match key="volume.fstype" string="ntfs">
        <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name" string="Linux">

<merge key="volume.fstype" type="string">ntfs-3g</merge>
<merge key="volume.policy.mount_filesystem" type="string">ntfs-3g</merge>

          <append key="volume.mount.valid_options" type="strlist">uid=</append>
          <append key="volume.mount.valid_options" type="strlist">gid=</append>
          <append key="volume.mount.valid_options" type="strlist">umask=</append>
          <append key="volume.mount.valid_options" type="strlist">dmask=</append>
          <append key="volume.mount.valid_options" type="strlist">fmask=</append>
          <append key="volume.mount.valid_options" type="strlist">locale=</append>
          <append key="volume.mount.valid_options" type="strlist">utf8</append>
        </match>

Efter vi har fået redigeret disse filer så skal hal genstartes med kommandoen /etc/rc.d/hal restart som skal køres som root. Sig til hvis det stadig ikke virker. Det er vigtigt at hal og ntfs-3g er installeret.

Kilder til dette indlæg:
http://wiki.archlinux.org/index.php/HAL#NTFS
http://wiki.archlinux.org/index.php/HAL … utomounter
http://bbs.archlinux.org/viewtopic.php?id=65348
http://bbs.archlinux.org/viewtopic.php?id=65648


Administrator for Archlinux.dk

Offline

 

Board footer

Powered by FluxBB