Dansk Arch Linux forum

For det danske Arch Linux community

Du er ikke logget ind.


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#1 03-09-2010 13:17:55

uldall
Ny på Archforum
Registreret: 18-08-2010
Indlæg: 10

[LØST] Specielle tegn i filnavne

Heja folkens.

Jeg har et generelt problem i Arch, som jeg nu ser mig nødsaget til at få ordnet:
Jeg bruger mpd/sonata til at afspille musik, og jeg er stor fan af Björk og Sigur Rós - Det er min Arch-installation tilsyneladende ikke, eller rettere sagt: Den er ikke ven med bogstaver som disse: ó, æ, ø, å, ä, ẽ og så videre, som den ikke kan vise korrekt, og mpd ignorerer mapper med disse tegn i navnet.

Pt er min encoding sat til UTF8, og går ud fra, at det har noget med det at gøre.

Hvordan kommer jeg til at kunne høre Bjórk igen?

Sidst ændret af uldall (03-09-2010 13:59:34)


Thinkpad T61 // Arch32 // Fluxbox

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

#2 03-09-2010 15:59:03

julemand101
Admin
Fra: Brabrand
Registreret: 18-04-2006
Indlæg: 780
Website

Re: [LØST] Specielle tegn i filnavne

Jeg har et ligneden problem (på ingen måde samme kunstnere som du nævner) men jeg kører så ISO-8859-1 på mit system (det er meget gammelt og da jeg installerede det brugte man ikke lige UTF-8). Har du tjekket /etc/mpd.conf og rettet følgende (detter er bare det der står i min og derfor skal du self. rette det til så det passer med dit system)?

Kode:

###################### CHARACTER ENCODINGS #####################
#
# If file or directory names do not display correctly, then you
# may need to change this.  In most cases it should be either
# "ISO-8859-1" or "UTF-8".  You must recreate your database
# after changing this (use mpd --create-db).
#
filesystem_charset              "ISO-8859-1"
#
# The encoding that ID3v1 tags should be converted from.
#
#id3v1_encoding                  "ISO-8859-1"
#
################################################################

Hvordan står filerne når du ser dem med kommandoen 'ls'? Står de korrekt der eller ser navnene underlige ud? (hvis de ser underlige ud er det fordi filnavnene er i et andet tegnsæt end din terminal som jo er sat til UTF-8).


Administrator for Archlinux.dk

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#3 05-09-2010 12:07:29

uldall
Ny på Archforum
Registreret: 18-08-2010
Indlæg: 10

Re: [LØST] Specielle tegn i filnavne

Det ændrer intet. Men problemet er også globalt.
Terminalen skriver ?-tegn i stedet for de drilske bogstaver.

Kan man ændre værdien i rc.conf fra "UTF8" til "ISO-8859-1" ?

Og vil det i så fald give uforudsete problemer?

Sidst ændret af uldall (05-09-2010 12:08:39)


Thinkpad T61 // Arch32 // Fluxbox

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#4 05-09-2010 12:42:16

julemand101
Admin
Fra: Brabrand
Registreret: 18-04-2006
Indlæg: 780
Website

Re: [LØST] Specielle tegn i filnavne

De eneste problemer det vil give er at filer du har oprettet med UTF-8 navne vil se underlige ud når du går over til ISO-8859-1. Men jeg synes at en bedre løsning vil være at konvertere alle filnavnene til UTF-8 i stedet for at flytte problemet ud i fremtiden. Jeg lavede en google søgning og fandt flere gode links:
http://www.google.dk/#hl=da&source= … 33943e2317

Men hvilke options har du prøvet at lave i mpd? Det undre mig nemlig meget at det ikke virker da det så heller ikke ændre noget at skifte indstillinger inde i rc.conf.


Administrator for Archlinux.dk

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 406

#5 05-09-2010 16:25:41

uldall
Ny på Archforum
Registreret: 18-08-2010
Indlæg: 10

Re: [LØST] Specielle tegn i filnavne

Hmm. Jeg kaster mig over convmv.

Hvordan finder man ud af hvilken encoding de problematiske filer har nu? Filerne og mapperne der værker er skabt på en dansksproget Windows XP SP2-installation, hvis det kan hjælpe.


Thinkpad T61 // Arch32 // Fluxbox

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#6 05-09-2010 19:47:19

julemand101
Admin
Fra: Brabrand
Registreret: 18-04-2006
Indlæg: 780
Website

Re: [LØST] Specielle tegn i filnavne

#5
Hvordan har du flyttet filerne? Normalt skal man altid sørge for at sætte mount eller samba op således at disse programmer konverterer korrekt mellem de forskellige tegnsæt. Hvis du ikke har valgt nogen indstillinger så kan vi gå ud fra at tegnsættet er denne: http://en.wikipedia.org/wiki/Windows-1252

Hvis filerne stadig ligger på en Windows og du ikke har ændret i dem på din Linux er løsningen nok at få fixet indstillingerne således at filerne bliver flyttet korrekt og hvor tegnsættet bliver korrekt rettet.


Administrator for Archlinux.dk

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 406

#7 20-09-2010 09:55:36

uldall
Ny på Archforum
Registreret: 18-08-2010
Indlæg: 10

Re: [LØST] Specielle tegn i filnavne

Filerne ligger på en ekstern harddisk, og filerne er "lavet" på en WinXPP SP2.
Jeg har imidlertid fundet ud af, hvad jeg havde gjort forkert:

Løsning
Jeg fandt ud af, at FAT32/NTFS-filer er UTF16 per default, og derfor skulle jeg sætte muligheden "utf8" i /etc/fstab, således at den detekterede tegnsættet korrekt.

Mange tak for hjælpen, du kan godt markere tråden som "LØST" nu:-)


Thinkpad T61 // Arch32 // Fluxbox

Offline

 

Board footer

Powered by FluxBB