Dansk Arch Linux forum

For det danske Arch Linux community

Du er ikke logget ind.


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 406

#1 17-06-2009 19:53:02

daxwarf
Ny på Archforum
Fra: Århus N
Registreret: 17-06-2009
Indlæg: 4

[LØST] Danske tegn i X (xfce, lxde)

Jeg har en Dell Studio 1537 som nu endelig kan starte XFCE. Men jeg KAN bare ikke skrive de danske tegn i en VC som f.eks. lxtemninal, og heller ikke i denne besked (;'[:"{).

# uname -a
... 2.6.30-ARCH #1 SMP PREEMPT Mon Jun 15 16:40:33 CEST 2009 x86_64 Intel(R) Core(TM)2 Duo CPU T6400 @ 2.00GHz GenuineIntel GNU/Linux
... runs like a dream, but ...

# lspci|grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3400 Series
# cat /etc/X11/xorg.conf |grep -i radeon
    Driver      "radeonhd"
    BoardName   "Mobility Radeon HD 3400 Series"
...have also tried xf86-video-ati

... jeg booter maskinen og logger ind i en TTY og skriver: Xorg -configure hvilket skaber xorg.conf.new som jeg redigerer (efter den udkommenterede Section InputDevice) if'lge de anvisninger jeg har kunnet finde her p[ forummet og kopierer filen til  /etc/X11/xorg.conf:

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard1" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/misc"
    FontPath     "/usr/share/fonts/100dpi:unscaled"
    FontPath     "/usr/share/fonts/75dpi:unscaled"
    FontPath     "/usr/share/fonts/TTF"
    FontPath     "/usr/share/fonts/Type1"
EndSection

Section "Module"
    Load  "dri"
    Load  "glx"
    Load  "drm"
    Load  "record"
    Load  "dbe"
    Load  "extmod"
    Load  "dri2"
EndSection

#Section "InputDevice"
#    Identifier  "Keyboard0"
#    Driver      "kbd"
#EndSection

#Her inds;tter jeg:
Section "InputDevice"
    Identifier  "Keyboard1"
    Driver      "kbd"
    Option "AutoRepeat" "500 30"
    Option "XkbRules"   "xorg"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "dk"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
    Identifier  "Card0"
    Driver      "radeonhd"
    VendorName  "ATI Technologies Inc"
    BoardName   "Mobility Radeon HD 3400 Series"
    BusID       "PCI:1:0:0"

    Option "AccelMethod" "exa"            # to enable 2D and Xv acceleration on R6XX - default AccelMethod shadowfb
    Option "DRI" "on"                     # to enable 2D and Xv acceleration on R6XX - default DRI disabled
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

... skriver: startxfce4 (med /etc/X11/xorg.conf)  Det skaber en ny /var/log/Xorg.0.log fil (size 890 lines), som jeg ikke vil belemre forumet med og har anvendt flg. komandoer til at hente det mest relevante:
 
# cat /var/log/Xorg.0.log|grep kbd
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.

# cat /var/log/Xorg.0.log|grep -i keyboard
(**) |-->Input Device "Keyboard1"
(WW) Disabling Keyboard1
(II) Initializing built-in extension XKEYBOARD
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event1"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(II) Video Bus: Configuring as keyboard
(II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)

# cat /var/log/Xorg.0.log|grep xkb
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"

# cat /var/log/Xorg.0.log|grep hal
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(II) config/hal: Adding input device Macintosh mouse button emulation
(II) config/hal: Adding input device AlpsPS/2 ALPS GlidePoint
(II) config/hal: Adding input device PS/2 Mouse
(II) config/hal: Adding input device Video Bus

... det forekommer mig, at X ikke tager min egne Section InputDevice alvorligt  (xkblayout=dk) og overlader til hal at finde mit KEYBOARD og anvende:
(**) Option "xkb_layout" "us"

... uanset at det har taget mig en 14 dages tid at n[ hertil, har jeg l;rt meget og synes arch og linux er helt kanon og vil gerne bidrage til at udbrede kendskabet til distributionen. Men jeg buger TTY og VC rimeligt meget og har brug for at komme over den her bakketop. Har ogs[  fors'gt med ATI proprietary drivers, men de konflikter med:

[root@loke ~]# pacman -Q glibc
glibc 2.10.1-2

H[ber der er nogle der kan hj;lpe, hvis ikke idag s[ m[ske f'r efter[ret s;tter ind. Jeg skal bare have Arch til at k're og beklager selvf'lgelig at denne besked mangler de danske tegn.

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

#2 17-06-2009 23:06:44

julemand101
Admin
Fra: Brabrand
Registreret: 18-04-2006
Indlæg: 780
Website

Re: [LØST] Danske tegn i X (xfce, lxde)

XFCE bruger ikke Xorg opsætningen til valg af tastaturlayout men derimod sit eget program som du kan starte med:
xfce-setting-show keyboard

Det skal siges at jeg ikke lige er helt sikker på denne del. Undersøg venligst først dette før du går videre med det jeg skriver.

Som du sikkert kan se så bruger Xorg ikke din xorg.conf til særlig meget og årsagen er her at Xorg slet ikke behøver en xorg.conf fil længere da HAL ordner den slags nu. Du kan derfor vælge at deaktivere autodetect af hardware inde i xorg.conf eller du kan vælge at sætte HAL sådan op at den vælger dansk tastaturlayout. Personligt vil jeg foretrække den sidste metode. Begge metoder er ret godt dokumenteret flere forskellige steder på wiki.archlinux.org og det undre mig en smule hvorfor du ikke har fundet nogen af de guides. Men altså her er den guide jeg foretrækker:
http://wiki.archlinux.org/index.php/Xor … _xorg.conf

Hvis det ikke virker kan du evt. prøve:
http://wiki.archlinux.org/index.php/Xor … d_Settings

Angående ATI driverne så er der en del problemer med disse men hvis du ikke allerede har prøvet så er der en del omkring emnet på følgende adresse:
http://wiki.archlinux.org/index.php/ATI

Jeg har selv et Nvidia kort så kan ikke sige så meget om ATI andet end:
http://www.archlinux.org/news/439/


Administrator for Archlinux.dk

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#3 18-06-2009 11:31:26

daxwarf
Ny på Archforum
Fra: Århus N
Registreret: 17-06-2009
Indlæg: 4

Re: [LØST] Danske tegn i X (xfce, lxde)

Tak julemand101, dit svar ledte mig på rette spor. I xfce4 findes  xfce4-keyboard-settings som er en grafisk brugerflade til at ændre keyboard settings. De mange metoder (afhængig af xorg-version) forvirrede mig og jeg ønskede at finde et centralt sted under /etc/..? at opsætte X til at anvende dansk keyboard uanset om jeg startede xfce4 eller lxde, men er kommet frem til at indsætte følgende i ~/.xinitrc:

setxkbmap dk
exec startlxde

... hvilket så må gøres pr. bruger. Det er OK og når jeg kører startxfce4 er de danske tegn også med her :-).

For fuldstændighedens skyld er mine settings i /etc/rc.conf og også her virker ÆØÅ:
LOCALE="en_US.utf8" #
HARDWARECLOCK="localtime"
USEDIRECTISA="yes"
TIMEZONE="Europe/Copenhagen"
KEYMAP="dk-latin1"
CONSOLEFONT=cp850-8x16.psfu.gz
CONSOLEMAP=8859-15
USECOLOR="yes"

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#4 18-06-2009 12:33:28

julemand101
Admin
Fra: Brabrand
Registreret: 18-04-2006
Indlæg: 780
Website

Re: [LØST] Danske tegn i X (xfce, lxde)

LXDE må da også have sit eget program til indstilling af keyboard map? Men ellers så er det rigtige metode følgende (som jeg også linkede til før):
http://wiki.archlinux.org/index.php/Xor … _xorg.conf

At nogen WM ikke lytter på dette og i stedet bruger sit eget program er bare noget du må acceptere og så ellers manuelt indstille de forskellige steder. Men ellers kan man sagtens bruge den metode du selv foreslår og så mange brugere er der vel ikke at det ligefrem er et problem.


Administrator for Archlinux.dk

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#5 18-06-2009 14:58:11

daxwarf
Ny på Archforum
Fra: Århus N
Registreret: 17-06-2009
Indlæg: 4

Re: [LØST] Danske tegn i X (xfce, lxde)

Hej julemand101

Jeg har fået det til at virke på en enkel måde og det var lige det jeg ønskede :-). Du kan markere tråden som LØST.

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#6 15-04-2010 10:45:08

Thumb
Ny på Archforum
Registreret: 02-07-2008
Indlæg: 3

Re: [LØST] Danske tegn i X (xfce, lxde)

Jeg køre fra command promt med "startx" og noget der virket for mig er :exec xset m 85/20 4 & setxkbmap dk -model evdev & xscreensaver & ck-launch-session awesome

Jeg køre "awesome" pt. og "-model evdev" løste mit problem med pile tast/AltGr key


Bop..Bop...Bop.. !!

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 406

#7 21-09-2010 14:48:03

daxwarf
Ny på Archforum
Fra: Århus N
Registreret: 17-06-2009
Indlæg: 4

Re: [LØST] Danske tegn i X (xfce, lxde)

Efter en nyere opdatering med pacman -Suy forsvandt de danske tegn igen, og det tog mig en rum tid at finde løsningen.

Under opdateringen overskrives /etc/locale.gen, så denne fil må editeres og de(t) ønskede locale udkommenteres (fjern #) foran ex. en_US.UTF-8.
Kør:
$> sudo locale-gen

Min løsning med at indsætte setxkbmap dk i .xinitrc er ikke længere nødvendig, da xorg kan håndtere dette som anvist:
http://wiki.archlinux.org/index.php/Xor … _xorg.conf
Ændringerne i den nye xorg er dog så omfattende at det vil spare mange tid, dels at læse: man xorg.conf og /usr/share/X11/xkb/rules/base.lst
hvis man har problemer med sit keyboard.

Jeg har denne opsætning:

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "dk,dk,us"
    Option "XkbVariant" ",nodeadkeys,"
    Option "XkbOptions" "grp:lwin_toggle,grp_led:scroll,terminate:ctrl_alt_bksp"
EndSection

placeret i /etc/X11/xorg.conf.
Det giver 3 layouts dk, dk med nodeadkeys og us, som jeg så kanskifte mellem med venstre windowstast.

Sidst ændret af daxwarf (22-09-2010 01:07:55)

Offline

 

Board footer

Powered by FluxBB