Dansk Arch Linux forum

For det danske Arch Linux community

Du er ikke logget ind.


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#1 04-08-2011 08:33:24

atte
Periodisk poster
Registreret: 05-06-2009
Indlæg: 32

Downgrade xorg

Hejsa

Jeg har nogle problemer med at kino (video editoren) crasher x. På kino's mailingliste henvises til https://bugs.gentoo.org/show_bug.cgi?id=374235 og jeg opfordres til at downgrade xorg til 1.9.

Er det muligt, gerne på en rimelig clean måde?

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 333

#2 05-08-2011 08:04:59

julemand101
Admin
Fra: Brabrand
Registreret: 18-04-2006
Indlæg: 773
Website

Re: Downgrade xorg

Det korte svar er nej. Arch Linux er rolling release og det har både fordele og ulemper at køre med seneste software og her er ulempen så det besværlige i at køre ting der kræver ældre versioner af softwarepakker. Hvis du ønsker at kunne køre med en ældre version af xorg findes der andre distributioner der ikke er rolling release.

Det mere kompliceret svar er ja men det kræver godt nok en hel del arbejde når vi snakker om xorg. Arch Linux versionstyre alle deres PKGBUILD filer så det er teoretisk muligt at hente alle PKGBUILD filer for xorg-server samt alle underliggende pakker og så bygge en tidligere version. Men da xorg består af en hel del pakker og sikkert også er afhængig af mindst lige så mange pakker der skal genbygges så vil det tage alt for lang tid at rette op på og jeg tror derfor der er større sandsynlighed for at kino løser deres problem inden du bliver færdig med at bygge pakker.

Arch Linux er ikke en distribution der er perfekt på alle måder og du er altså stødt ind i et problem ved rolling release som ikke er så nemt at rette op på.


Administrator for Archlinux.dk

Offline

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/vzn258/domains/archlinux.dk/public_html/forum/include/parser.php on line 349

#3 13-08-2011 17:34:39

nbca
Periodisk poster
Registreret: 25-08-2010
Indlæg: 35

Re: Downgrade xorg

Det er muligt at downgrade xorg, men har du først installeret xorg 1.10 er det en større operation.

I forbindelse med ATI Catalyst driveren, der er unsupported, er der oprettet en række (uofficielle) repos, der tilbyder xorg 1.8 og 1.9, de hedder hhv.

Kode:

[xorg18]
  Server = http://catalyst.apocalypsus.net/repo/xorg18/$arch

Kode:

\[xorg19\]
  Server = http://catalyst.apocalypsus.net/repo/xorg19/$arch

De skal placeres over extra, hvori xorg ligger, det anbefales at den ligeledes ligger over core.

Det bedste, ideelt set ville være at fjerne xorg og geninstallere det, du kan ikke blot opgradere, da xorg 1.9 er ældre end xorg 1.10.

Offline

 

Board footer

Powered by FluxBB